名客技术网

简体
繁体
×警告!请输入搜索关键词(仅提示一次)
网站建设电话:15927179345(资深程序)

jdk1.8+Tomcat7.0小版本无法兼容问题解决

作者:网站小编时间:2019-02-18 15:02:19

用的jdk1.8跑的是Tomcat7.0的小版本,默认的Tomcat和jdk向下兼容的,但启动报编译的错误。

出现这个错误:

1:把jdk1.8换成1.7是可以解决。

2:把tomcat换成8也是可以解决的。

如果想解决jdk1.8和tomcat7的兼容问题本质是是ecj.jar的问题:

因为在tomcat7中读取版本信息的ecj.jar默认的版本是3..7.2里面读取信息还是之前jdk版本。所以不兼容,只需要把原来Tomcat7中lib包下面的ecj3.7.2换成ecj.4.4.2这个版本就可以解决jdk1.8+Tomcat7兼容的问题,启动就不会报编译的错误 。

名客技术网如果无意之中侵犯了您的版权,请联系站长,本站将在3个工作日内删除 QQ:175352796
Copyright 2011-2020 Powered by 121ASK.COM, All Rights Reserved.
备案号:鄂ICP备11013833号-3